Distribution Packages fail randomly during Provisioning
Distribution Packages fail to install randomly during using Provisioning
- A device in the process of being provisioned will often have the following steps:
- Prepare the hard drive and deploy the OS (either through image deployment or scripted install)
- Join the domain and other first start actions
- Install the LANDesk Agent
- Using the LANDesk Agent install software deployment packages, patch the system, etc.
PROBLEM
There is a known issue that can cause seemingly random software deployment failures in step 4. The issue is that when the LANDesk agent is installed it will enter the local scheduler information for the client machine to run a security scan and a policy sync. Because of the way our scheduler works these will attempt ro run immediately, but with up to a 60 minute random delay. (Note: This is a default setting and can be changed)
The problem occurs if the security scan or a policy task gets initiated and is running when a distribute software provisioning action starts. In that scenario the distribute software action will attempt to run the task, view that the other task is already running, and exit with a failure.
If you have multiple distribute software actions chained together you will likely see the process fail on different packages. This is because of the random delay at the start time that will make it so you might get the error early on, later in the process, or sometimes even succeed completely.
CAUSE
When our software distribution agent runs (sdclient.exe) it will perform a check to make sure that no other task is running. It will check for any other instances of sdclient, any instances of vulscan (security scanner), and also do a few other checks that aren't relevant here. If it sees sdclient.exe or vulscan.exe already running it will return an exit code that a task is already in progress, so it can't run. As we described in the previous section, our agent deployment will launch vulscan.exe within an hour of agent deployment. This can cause a provisioning distribute software action to fail.
In addition to the possible timing of another task starting before our software deployment agent can run there is the feature that vulscan.exe (security scanner) is very persistent. Because it relates to security of the device it will not immediately fail if it sees a different task already running; it will wait until the other task finishes. This is the most common scenario for the tasks to fail. The process looks something like this:
RESOLUTION
To work around this known problem you can create an agent to be used for provisioning that does not start the security scan or the policy sync immediately upon installing the agent. Â We don't have the option to disable the tasks completely, but we can set them to start at some point in the future, such as the year 3000. Â That should give us enough time.
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After all distribute software or patch system tasks have completed you can then finish the provisioning template by installing the agent you would actually like to use on the device long term.
To work around this known problem a LANDesk Agent was created specifically for provisioning (Tufts_95_SP1_Provisioning_Agent) that does not start the security scan or the policy sync immediately upon installing the agent. Â We don't have the option to disable the tasks completely, but we can set them to start at some point in the future, such as the year 3000. Â Once your software distribution tasks are completed the last step should be to install the full LANDesk Agent that you want to use in production.
EXAMPLE
For more information please see this article:Â http://community.landesk.com/support/docs/DOC-9526
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